Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000004 [MyDNS-NG] Global crash always 2008-02-19 23:54 2008-02-20 10:08
Reporter jorge View Status public  
Assigned To howardwilkinson
Priority normal Resolution fixed  
Status closed   Product Version 1.2.7
Summary 0000004: Crash with 1.2.7 Pre
Description I was trying 1.2.7-Pre, and i have this:

Feb 19 23:46:19 dnsserver mydns[23803]: *** glibc detected *** /usr/local/sbin/mydns: munmap_chunk(): invalid pointer: 0x0827e459 ***

I belive it's when i try to query the server because it returns nothing.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0000011)
howardwilkinson (administrator)
2008-02-20 10:08

Missed a check in the code for existence of the edata column. Please add a column edata BLOB to rr and retest!

A fix has been uploaded to sourceforge so you can download and try that as well.

- Issue History
Date Modified Username Field Change
2008-02-19 23:54 jorge New Issue
2008-02-19 23:54 jorge Status new => assigned
2008-02-19 23:54 jorge Assigned To => howardwilkinson
2008-02-19 23:54 jorge Issue Monitored: jorge
2008-02-20 10:08 howardwilkinson Status assigned => closed
2008-02-20 10:08 howardwilkinson Note Added: 0000011
2008-02-20 10:08 howardwilkinson Resolution open => fixed
2008-02-20 10:08 howardwilkinson Fixed in Version => 1.2.7


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker