Mantis Bugtracker

Viewing Issue Advanced Details Jump to Notes ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000046 [MyDNS-NG] Global tweak always 2010-02-16 11:37 2010-02-19 16:36
Reporter netserve View Status public  
Assigned To tlamy
Priority low Resolution reopened Platform
Status assigned   OS
Projection none   OS Version
ETA none Fixed in Version Product Version 1.2.8.29
  Target Version Product Build
Summary 0000046: Segmentation fault on startup
Description Backed up database from mydns to mydns.bac in /var/lib/mysql.
Stop mydns, restart it.

Mydns reports the error that mydns.old is not a valid database name even though it is not referenced anywhere in the mydns.conf. Mydns then seg faults.

Logging into mysql does not show any errors.

Somewhere along the line error messages from mysql about having an invalid database name are leaking into Mydns even if the databases are not in use within mydns.

Steps To Reproduce
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0000138)
jasb (reporter)
2010-02-16 13:19

Tell me,
You 1st said you backup'd up the DB to mydns.bac
Then after you wrote mydns.old.

Can you clarify this part?
(0000139)
jasb (reporter)
2010-02-16 13:21

I understood sorry,
This doesn't happen, which version are you using?
(0000140)
tlamy (developer)
2010-02-19 15:40
edited on: 2010-02-19 15:41

This is from mydns trying to get the maximum string length from various database fields, where it queries INFORMATION_SCHEMA.

But indeed, mydns.bac is, by definition, not a valid mysql database name (dots are not allowed in database names).

Will look at it as soon as time permits.

(0000141)
jorge (administrator)
2010-02-19 15:50

Tom,
MySQL does not even allow to create "mydns.bac".
So a manual "cp mydns mydns.bac" on the MySQL datadir should not happen anyway, if a backup is done with this name it should be kept outside the datadir.
(0000142)
tlamy (developer)
2010-02-19 15:53

Won't fix, due to mysql limitations (see notes for full explanation)
(0000143)
netserve (reporter)
2010-02-19 16:03

From a user perspective, if I copy a database to a directory called mydns.bac while it's not a valid database name then if I break mysql, that's my fault but I'd expect mysql to tell me about the invalid database name.

If Mysql carries on running but somehow mydns breaks, that doesn't seem right.

Is mydns looking beyond the database referenced in the .conf file or is it not handling an error from mysql correctly?

Either way I think mydns should in part protect the user from what is seemingly an easy mistake to make.
(0000144)
tlamy (developer)
2010-02-19 16:36

Ok, I'll dig into it. If the fix is trivial, it will make it into 1.2.8.30, which I plan to tie together next week

- Issue History
Date Modified Username Field Change
2010-02-16 11:37 netserve New Issue
2010-02-16 13:19 jasb Note Added: 0000138
2010-02-16 13:21 jasb Note Added: 0000139
2010-02-19 15:40 tlamy Note Added: 0000140
2010-02-19 15:41 tlamy Note Edited: 0000140
2010-02-19 15:50 jorge Note Added: 0000141
2010-02-19 15:53 tlamy Note Added: 0000142
2010-02-19 15:53 tlamy Status new => closed
2010-02-19 15:53 tlamy Resolution open => won't fix
2010-02-19 16:03 netserve Note Added: 0000143
2010-02-19 16:03 netserve Status closed => feedback
2010-02-19 16:03 netserve Resolution won't fix => reopened
2010-02-19 16:35 tlamy Assigned To => tlamy
2010-02-19 16:35 tlamy Priority normal => low
2010-02-19 16:35 tlamy Status feedback => assigned
2010-02-19 16:35 tlamy Description Updated
2010-02-19 16:36 tlamy Note Added: 0000144


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker