Mantis Bugtracker

Viewing Issue Advanced Details Jump to Notes ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000018 [MyDNS-NG] Global minor always 2009-04-22 15:21 2014-08-07 18:52
Reporter owaldheim View Status public  
Assigned To jameno123
Priority normal Resolution fixed Platform
Status resolved   OS
Projection none   OS Version
ETA none Fixed in Version 1.2.8.32 Product Version 1.2.8
  Target Version 1.2.8.32 Product Build
Summary 0000018: Syntax error in notify.c
Description I have Solaris 10 x86 and
#undef HAVE_GETADDRINFO
and get
notify.c:905: error: syntax error before numeric constant
notify.c:905: error: conflicting types for 'array_free'
named.h:129: error: previous declaration of 'array_free' was here
notify.c:905: error: conflicting types for 'array_free'
named.h:129: error: previous declaration of 'array_free' was here
notify.c:905: warning: data definition has no type or storage class
notify.c:906: error: syntax error before numeric constant
notify.c:906: warning: data definition has no type or storage class
Steps To Reproduce
Additional Information With this precompiler definition the number of opening and closing brackets are not equal for the function name_servers2ip. I switched lines 783/784 in file src/mydns/notify.c:

    /* Look up via other DNS/hosts instead */
    {
#if HAVE_GETADDRINFO
      struct addrinfo hosthints;
      struct addrinfo *hostdata = NULL;
      struct addrinfo *hostentry;
Tags No tags attached.
Attached Files

- Relationships
duplicate of 0000057resolvedjameno123 Fails to build on OpenSolaris 
related to 0000056feedbackjameno123 Current code assumes AI_ADDRCONFIG is always present in netdb.h 

-  Notes
(0000074)
howardwilkinson (administrator)
2009-06-28 12:11

Will fix in 1.2.8.28 & 1.2.9.0, thank you!
(0000204)
jameno123 (administrator)
2014-08-05 23:39

This *should* be fixed fully in the latest git-master (and hopefully wont create any new ones like it):
https://sourceforge.net/p/mydns-ng/code/ci/c4b73474301b8b3ef32759aa9dcb33dbbece91ff/ [^] [^]

Found a case of mis-aligned scoping brackets under certain compiler options. Adjusted the scoping bracket locations to correct the problem. Please re-open if there is any troubles with the latest commits.

- Issue History
Date Modified Username Field Change
2009-04-22 15:21 owaldheim New Issue
2009-05-03 12:09 jorge Status new => assigned
2009-05-03 12:09 jorge Assigned To => howardwilkinson
2009-06-28 12:11 howardwilkinson Note Added: 0000074
2009-06-28 12:11 howardwilkinson Status assigned => acknowledged
2010-06-22 20:50 jwarnier Issue Monitored: jwarnier
2014-08-05 23:39 jameno123 Relationship added duplicate of 0000057
2014-08-05 23:39 jameno123 Status acknowledged => assigned
2014-08-05 23:39 jameno123 Assigned To howardwilkinson => jameno123
2014-08-05 23:39 jameno123 Note Added: 0000204
2014-08-05 23:39 jameno123 Status assigned => resolved
2014-08-05 23:39 jameno123 Fixed in Version => Trunk
2014-08-05 23:39 jameno123 Resolution open => fixed
2014-08-05 23:49 jameno123 Relationship added related to 0000056
2014-08-07 18:52 jameno123 Fixed in Version Trunk => 1.2.8.32
2014-08-07 18:52 jameno123 Target Version => 1.2.8.32


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker