Mantis Bugtracker

Viewing Issue Advanced Details Jump to Notes ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000043 [MyDNS-NG] Global minor always 2009-12-17 15:11 2009-12-22 20:27
Reporter Fab View Status public  
Assigned To tlamy
Priority normal Resolution fixed Platform
Status resolved   OS
Projection none   OS Version
ETA none Fixed in Version Trunk Product Version 1.2.8.27
  Target Version Product Build
Summary 0000043: the TLD is added twice in the answer of the authority section when requesting the A record of an delegated sub domain.
Description Proof:
dig sub.domain.de A

########
;; QUESTION SECTION:
;sub.domain.de. IN A

;; AUTHORITY SECTION:
sub.domain.de.domain.de. 40000 IN NS ns1.otherdomain.de.
sub.domain.de.domain.de. 40000 IN NS ns2.otherdomain.de.
########

the answer should be:

########
;; QUESTION SECTION:
;sub.domain.de. IN A

;; AUTHORITY SECTION:
sub.domain.de. 40000 IN NS ns1.otherdomain.de.
sub.domain.de. 40000 IN NS ns2.otherdomain.de.
########

Steps To Reproduce
Additional Information the problem is fixed already in attached version of mydns-ng 1.2.8.27 ( problem http://bugs.mydns-ng.com/view.php?id=42) [^] is fixed in this archive too.

Please verify the Problem and check whether the fix is correct.

See attached setup.png and mydns.sql.gz for details of our setup
Tags No tags attached.
Attached Files tgz file icon mydns-1.2.8-patched.tgz [^] (1,052,972 bytes) 2009-12-17 15:11
png file icon setup.png [^] (106,728 bytes) 2009-12-17 15:12
gz file icon mydns.sql.gz [^] (1,121 bytes) 2009-12-17 15:12

- Relationships

-  Notes
(0000125)
tlamy (developer)
2009-12-17 17:42

Tanks again for your work, will test and report back
(0000132)
tlamy (developer)
2009-12-22 20:27

Fixed with svn revision 213

- Issue History
Date Modified Username Field Change
2009-12-17 15:11 Fab New Issue
2009-12-17 15:11 Fab File Added: mydns-1.2.8-patched.tgz
2009-12-17 15:12 Fab File Added: setup.png
2009-12-17 15:12 Fab File Added: mydns.sql.gz
2009-12-17 15:14 Fab Issue Monitored: Fab
2009-12-17 17:42 tlamy Note Added: 0000125
2009-12-17 17:42 tlamy Assigned To => tlamy
2009-12-17 17:42 tlamy Status new => assigned
2009-12-22 20:27 tlamy Note Added: 0000132
2009-12-22 20:27 tlamy Status assigned => resolved
2009-12-22 20:27 tlamy Fixed in Version => Trunk
2009-12-22 20:27 tlamy Resolution open => fixed


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker